Cannot get new tasks on one of my AMD Rigs 4P

Message boards : Number crunching : Cannot get new tasks on one of my AMD Rigs 4P
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile bcavnaugh
Avatar

Send message
Joined: 4 Aug 14
Posts: 5
Credit: 4,141,688
RAC: 973
Message 1109 - Posted: 13 Sep 2014, 16:22:42 UTC

Computer ID: 19754
I have reset the project a number of times.
I can get tasks on my other AMD 2P rig ID: 19668
Any tricks to get this fixed?
Thanks, Bill
ID: 1109 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Greg Tucker
Project administrator
Project developer
Project tester

Send message
Joined: 8 Jul 11
Posts: 46
Credit: 7,144,042
RAC: 0
Message 1110 - Posted: 13 Sep 2014, 19:37:12 UTC - in response to Message 1109.  

Computer ID: 19754
I have reset the project a number of times.
I can get tasks on my other AMD 2P rig ID: 19668
Any tricks to get this fixed?
Thanks, Bill


Could it be on the wrong settings for home/work/school as in this thread http://numberfields.asu.edu/NumberFields/forum_thread.php?id=191#1002
ID: 1110 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1176
Credit: 201,092,833
RAC: 197,607
Message 1111 - Posted: 13 Sep 2014, 22:37:07 UTC - in response to Message 1110.  

You could also look at the event log for hints. Let me know if it says something like "No tasks available", since that would be a scheduler problem.

You could also look at the NumberFields preferences and make sure at least one of the apps is selected; and change this to yes: "If no work for selected applications is available, accept work from other applications?".
ID: 1111 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile bcavnaugh
Avatar

Send message
Joined: 4 Aug 14
Posts: 5
Credit: 4,141,688
RAC: 973
Message 1112 - Posted: 14 Sep 2014, 2:56:29 UTC
Last modified: 14 Sep 2014, 3:19:03 UTC

Looking now on both. Thanks
I have the settings the same as my 2P Rig ID: 19668

Here is my log file:

Sat 13 Sep 2014 09:07:05 PM MDT | NumberFields@home
| URL http://numberfields.asu.edu/NumberFields/; Computer ID 19754; resource share 100
Sat 13 Sep 2014 09:07:05 PM MDT |
| General prefs: from http://www.rechenkraft.net/yoyo/ (last modified 11-Sep-2014 20:44:55)
Sat 13 Sep 2014 09:07:05 PM MDT |
| Computer location: school
Sat 13 Sep 2014 09:07:05 PM MDT |
| General prefs: no separate prefs for school; using your defaults
Sat 13 Sep 2014 09:07:05 PM MDT |
| Reading preferences override file
Sat 13 Sep 2014 09:07:05 PM MDT | | Preferences:
Sat 13 Sep 2014 09:07:05 PM MDT |
| max memory usage when active: 30222.93MB
Sat 13 Sep 2014 09:07:05 PM MDT | | max memory usage when idle: 31509.01MB
Sat 13 Sep 2014 09:07:05 PM MDT |
| max disk usage: 220.00GB
Sat 13 Sep 2014 09:07:05 PM MDT | | max CPUs used: 60
Sat 13 Sep 2014 09:07:05 PM MDT |
| (to change preferences, visit a project web site or select Preferences in the Manager)
Sat 13 Sep 2014 09:07:05 PM MDT |
| gui_rpc_auth.cfg is empty - no GUI RPC password protection
Sat 13 Sep 2014 09:07:05 PM MDT | | Not using a proxy


Is it looking OK?


I now see this:
Sat 13 Sep 2014 09:07:05 PM MDT |
| Computer location: school

I do not have a school setup anymore but will create one and re-test.
ID: 1112 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile bcavnaugh
Avatar

Send message
Joined: 4 Aug 14
Posts: 5
Credit: 4,141,688
RAC: 973
Message 1113 - Posted: 14 Sep 2014, 4:04:44 UTC
Last modified: 14 Sep 2014, 4:50:06 UTC

BAM! might me my issue. Now taking a look.

Up and Running Now!
ID: 1113 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1176
Credit: 201,092,833
RAC: 197,607
Message 1114 - Posted: 14 Sep 2014, 5:04:08 UTC - in response to Message 1113.  

If you click update and watch the event log you should see messages that say something like "Requesting xx tasks" or "Not requesting tasks", followed by the server response which usually tells you why it won't give you tasks.

Hope that helps.
ID: 1114 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ChertseyAl

Send message
Joined: 19 Aug 11
Posts: 45
Credit: 1,014,069
RAC: 0
Message 1115 - Posted: 15 Sep 2014, 16:50:07 UTC

I haven't been able to get any work for weeks now, except for on just one machine. I always get something like this:

15/09/14 14:41:14|NumberFields@home|Sending scheduler request: To fetch work. Requesting 446 seconds of work, reporting 0 completed tasks
15/09/14 14:41:19|NumberFields@home|Scheduler request succeeded: got 0 new tasks
15/09/14 14:41:19|NumberFields@home|Message from server: No tasks sent
15/09/14 14:41:19|NumberFields@home|Message from server: No tasks are available for Get Decic Fields


Actually, it's probably longer than that. I've tried detaching/reattaching but it makes no difference. Perhaps the server is refusing to send work to older client versions.

Shame. I was planning on crunching my way up to the 1M credit level.
ID: 1115 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1176
Credit: 201,092,833
RAC: 197,607
Message 1116 - Posted: 16 Sep 2014, 4:23:07 UTC - in response to Message 1115.  

I haven't been able to get any work for weeks now, except for on just one machine. I always get something like this:

15/09/14 14:41:14|NumberFields@home|Sending scheduler request: To fetch work. Requesting 446 seconds of work, reporting 0 completed tasks
15/09/14 14:41:19|NumberFields@home|Scheduler request succeeded: got 0 new tasks
15/09/14 14:41:19|NumberFields@home|Message from server: No tasks sent
15/09/14 14:41:19|NumberFields@home|Message from server: No tasks are available for Get Decic Fields


Actually, it's probably longer than that. I've tried detaching/reattaching but it makes no difference. Perhaps the server is refusing to send work to older client versions.

Shame. I was planning on crunching my way up to the 1M credit level.


There is definitely work available, so possibly it is the older client that's the problem.

One thing that stands out is that your client is only requesting 446 seconds of work. My log usually reads "Requesting new tasks for CPU" and does not specify the amount of time. Could you modify your preferences so that it requests more work? The current batch of decics WUs are averaging between 3 and 4 hours on a higher end computer, so 446 seconds is probably insufficient.
ID: 1116 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ChertseyAl

Send message
Joined: 19 Aug 11
Posts: 45
Credit: 1,014,069
RAC: 0
Message 1117 - Posted: 16 Sep 2014, 6:01:23 UTC - in response to Message 1116.  

Tried that before, I'll try again ...

16/09/14 06:59:30|NumberFields@home|Sending scheduler request: Requested by user. Requesting 95040 seconds of work, reporting 0 completed tasks
16/09/14 06:59:35|NumberFields@home|Scheduler request succeeded: got 0 new tasks
16/09/14 06:59:35|NumberFields@home|Message from server: No tasks sent
16/09/14 06:59:35|NumberFields@home|Message from server: No tasks are available for Get Decic Fields


Nope. It's not just one machine either, it's (I think) all but one of them.
ID: 1117 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Richard Haselgrove

Send message
Joined: 28 Oct 11
Posts: 175
Credit: 149,763,612
RAC: 39,635
Message 1118 - Posted: 16 Sep 2014, 7:49:43 UTC - in response to Message 1116.  

There is definitely work available, so possibly it is the older client that's the problem.

One thing that stands out is that your client is only requesting 446 seconds of work. My log usually reads "Requesting new tasks for CPU" and does not specify the amount of time. Could you modify your preferences so that it requests more work? The current batch of decics WUs are averaging between 3 and 4 hours on a higher end computer, so 446 seconds is probably insufficient.

A server bug was recently found and fixed, because of similar behaviour at SETI@home. Eric, could you apply these two related updates?

http://boinc.berkeley.edu/gitweb/?p=boinc-v2.git;a=commit;h=6c5849d817c9dbbf1e94677029037c6e4abab4d0
scheduler: fix bug that caused no jobs to be sent to pre-6.7 clients

http://boinc.berkeley.edu/gitweb/?p=boinc-v2.git;a=commit;h=60a35821517fb686087aa56bd6dc86134d313a85
scheduler: if client reports zero elapsed time, set ET to CPU time

Client version 5.10.45, although very old, should still be supported because it's the last version which can be installed on Windows Domain Controllers.

The low number of seconds of work requested is no problem at all. The server should send out new work, even if only 1 second is requested.
ID: 1118 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1176
Credit: 201,092,833
RAC: 197,607
Message 1119 - Posted: 16 Sep 2014, 14:21:03 UTC - in response to Message 1118.  

There is definitely work available, so possibly it is the older client that's the problem.

One thing that stands out is that your client is only requesting 446 seconds of work. My log usually reads "Requesting new tasks for CPU" and does not specify the amount of time. Could you modify your preferences so that it requests more work? The current batch of decics WUs are averaging between 3 and 4 hours on a higher end computer, so 446 seconds is probably insufficient.

A server bug was recently found and fixed, because of similar behaviour at SETI@home. Eric, could you apply these two related updates?

http://boinc.berkeley.edu/gitweb/?p=boinc-v2.git;a=commit;h=6c5849d817c9dbbf1e94677029037c6e4abab4d0
scheduler: fix bug that caused no jobs to be sent to pre-6.7 clients

http://boinc.berkeley.edu/gitweb/?p=boinc-v2.git;a=commit;h=60a35821517fb686087aa56bd6dc86134d313a85
scheduler: if client reports zero elapsed time, set ET to CPU time

Client version 5.10.45, although very old, should still be supported because it's the last version which can be installed on Windows Domain Controllers.

The low number of seconds of work requested is no problem at all. The server should send out new work, even if only 1 second is requested.


Thanks Richard. I will apply those patches tonight when I get home from work.
ID: 1119 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1176
Credit: 201,092,833
RAC: 197,607
Message 1120 - Posted: 17 Sep 2014, 4:28:48 UTC - in response to Message 1119.  

I applied the patches and restarted the server.

Al:
When you get a chance, can you try again and see if it works for you? Thanks!
ID: 1120 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ChertseyAl

Send message
Joined: 19 Aug 11
Posts: 45
Credit: 1,014,069
RAC: 0
Message 1121 - Posted: 17 Sep 2014, 5:55:47 UTC - in response to Message 1120.  


Al:
When you get a chance, can you try again and see if it works for you? Thanks!


Just tried:

17/09/14 06:52:50|NumberFields@home|Sending scheduler request: Requested by user. Requesting 95040 seconds of work, reporting 0 completed tasks
17/09/14 06:52:56|NumberFields@home|Scheduler request succeeded: got 2 new tasks
17/09/14 06:52:59|NumberFields@home|Started download of sf3_DS-13x267_Grp25113of25600.dat
17/09/14 06:52:59|NumberFields@home|Started download of sf3_DS-13x267_Grp25030of25600.dat
17/09/14 06:53:00|NumberFields@home|Finished download of sf3_DS-13x267_Grp25113of25600.dat
17/09/14 06:53:00|NumberFields@home|Finished download of sf3_DS-13x267_Grp25030of25600.dat
17/09/14 06:53:02|NumberFields@home|Starting wu_sf3_DS-13x267_Grp25113of25600_0
17/09/14 06:53:02|NumberFields@home|Starting task wu_sf3_DS-13x267_Grp25113of25600_0 using GetDecics version 102


Hurrah! I'll switch the rest of my hosts to this project later and see how it goes :)

Cheers,

Al.
ID: 1121 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Cannot get new tasks on one of my AMD Rigs 4P


Main page · Your account · Message boards


Copyright © 2022 Arizona State University