NumberFields@home still under construction

Message boards : News : NumberFields@home still under construction
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 1 - Posted: 8 Aug 2011, 6:26:47 UTC

We are still working out a few issues with the client app and hope to have the project fully operational in the next couple of weeks.
ID: 1 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Aleksander Parkitny

Send message
Joined: 19 Aug 11
Posts: 1
Credit: 128,173
RAC: 0
Message 10 - Posted: 19 Aug 2011, 11:58:31 UTC - in response to Message 1.  

If You would like a Polish translation :d

http://www.boincatpoland.org/wiki/NumberFields@home

greetings form BOINC@Poland :D
ID: 10 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Greg Tucker
Project administrator
Project developer
Project tester

Send message
Joined: 8 Jul 11
Posts: 45
Credit: 7,144,042
RAC: 0
Message 12 - Posted: 19 Aug 2011, 16:38:32 UTC - in response to Message 10.  

Wow, this is great. Thanks. Go team Poland!
ID: 12 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile philip-in-hongkong

Send message
Joined: 20 Aug 11
Posts: 1
Credit: 735,832
RAC: 566
Message 21 - Posted: 20 Aug 2011, 4:03:57 UTC - in response to Message 12.  

Just join the project and no WU for my Windows/x86. Could it be possible to add the link to server status on the front page?
ID: 21 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 25 - Posted: 20 Aug 2011, 8:48:01 UTC - in response to Message 21.  

Sorry about that. I hadn't anticipated so many new volunteers, so the project ran out of work. Should be good now. I still need to automate the work creation process so that this wont happen again.
ID: 25 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 26 - Posted: 20 Aug 2011, 8:51:29 UTC - in response to Message 25.  

And yes, I will add a link to server status on the main page. Thanks for the suggestion.
ID: 26 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Conan
Avatar

Send message
Joined: 3 Sep 11
Posts: 26
Credit: 2,366,782
RAC: 1,198
Message 481 - Posted: 10 Mar 2012, 9:54:12 UTC

I know that the project has been running fine for a while now but I am having a few project start up type issues.

I have to constantly re-log into my account every time I back out of the account page (not log out just use backspace to return to the main page to post on the Forum for instance), and then try go back to my account page.

If I go to my account I am asked to log in, even though I have the "Stay logged In" box ticked.
I log in and all OK whilst I am in the account, I then back out so I can go to the Forum to post or read the messages.
If I try to post I am asked to log in again as the system has logged me out when I backed out of my Account page.

I can only add to existing Threads as there is no way to start a new Thread due to the fact that I am no longer logged in.
(This is why I have restarted this thread).

It is getting a bit tiresome to be constantly logging in all the time. My other project are not doing this.

I use Firefox on a AMD Phemon X4 955 computer running Fedora 16 64 bit.

Thanks

Conan
ID: 481 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 492 - Posted: 10 Mar 2012, 19:46:46 UTC - in response to Message 481.  

Ok. I was able to duplicate your problem. Until I figure this out, here is a short term solution. In fact this is how I normally operate, which is why I never realized there was a problem:

If you never go back past the original log in screen, then you will remain logged in. So for example, from the account page scroll to the bottom and click on message boards, then you can post without the login problem. Every page has the same basic links at the bottom which can take you to your account, the main page, or the message boards, without having to go backwards. I hope that is useful in the short term...

It's odd that this doesn't happen on other projects, since most projects use the same php/html code base. Maybe they have a recent update that I don't???
ID: 492 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Conan
Avatar

Send message
Joined: 3 Sep 11
Posts: 26
Credit: 2,366,782
RAC: 1,198
Message 493 - Posted: 11 Mar 2012, 0:02:43 UTC - in response to Message 492.  

Thanks Eric,

I will do that, but to me it is annoying for as I said I just go back and forth using the browser not specific links. Been doing it like this for years.

There are one or two other projects this has happened on, but mostly they get fixed or I stop going to my account page on those projects.

Thanks
Conan
ID: 493 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
frankhagen

Send message
Joined: 19 Aug 11
Posts: 76
Credit: 2,002,860
RAC: 0
Message 495 - Posted: 11 Mar 2012, 13:49:37 UTC - in response to Message 493.  

well eric,

you missed some of the URL's when changing them.


some still point to http://stat.la.asu.edu/NumberFields/...
ID: 495 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
spingadus[MM]

Send message
Joined: 19 Aug 11
Posts: 5
Credit: 500,305
RAC: 0
Message 496 - Posted: 11 Mar 2012, 19:00:05 UTC

I can't reproduce the login problem with either the latest chrome or firefox. I stay logged in.
ID: 496 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
zombie67 [MM]
Avatar

Send message
Joined: 19 Aug 11
Posts: 28
Credit: 30,480,904
RAC: 0
Message 497 - Posted: 12 Mar 2012, 0:12:59 UTC

It happens to me too. There are a few BOINC sites with this problem.
Dublin, CA
Team SETI.USA
ID: 497 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 498 - Posted: 12 Mar 2012, 5:31:30 UTC - in response to Message 495.  

well eric,

you missed some of the URL's when changing them.


some still point to http://stat.la.asu.edu/NumberFields/...



NumberFields.asu.edu is an alias for stat.la.asu.edu (i.e. they resolve to the exact same ip address) so other than looking inconsistent, it shouldn't cause a problem.
ID: 498 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 499 - Posted: 12 Mar 2012, 5:38:57 UTC - in response to Message 496.  

I can't reproduce the login problem with either the latest chrome or firefox. I stay logged in.


That's interesting. Did you keep hitting the back button until it went past the initial login screen (I had to go backwards ~20 times to see the problem)? Another symptom of the problem is if you are logged in and then open a new tab. You will have to log in again, when it should remember that you are already logged in.
ID: 499 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 500 - Posted: 12 Mar 2012, 5:49:10 UTC - in response to Message 497.  

It happens to me too. There are a few BOINC sites with this problem.


I have a mirror image of the NumberFields site on my home computer that I use for testing before I make changes on the official site. The mirror site runs the exact same version of the boinc software, and does not have this problem.
ID: 500 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Richard Haselgrove

Send message
Joined: 28 Oct 11
Posts: 128
Credit: 104,480,854
RAC: 26,134
Message 501 - Posted: 12 Mar 2012, 10:46:10 UTC

Sometimes this can be a corrupted login cookie, perhaps relating to the old address. Deleting all cookies relating in any way to the project and starting from scratch can clear it.
ID: 501 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Conan
Avatar

Send message
Joined: 3 Sep 11
Posts: 26
Credit: 2,366,782
RAC: 1,198
Message 502 - Posted: 12 Mar 2012, 12:34:34 UTC

G'Day Eric,
I don't have to hit the 'Back' button 20 times to get this issue to occur.

For others that don't understand what my problem is (well at least this problem, not all my other ones), I will go through the steps.

I open up the Projects Web page and then click on the "Account" link.
The "Log In" screen appears and I Log In.
I check things in my account and then want to go back to the Main Project Page to check out a few other things, for this I use the "Back" button on my browser.

It takes me a couple of "Back" presses to get back to the main page going back past the Log In screen in the process.

I click another link (say to Messages or Server Status) and look around the web site or read the message posts to see what is happening.

I then need to go back to my account page so I have to click on the "Account" link and it takes back to the "Log In" screen again, and I have to log back in to see my account.

If when I am viewing the messages and I want to post I am asked to Log In again as well.

To create a new thread I have to do what Erik suggested and not use the "Back" browser button but use the links at the bottom of my account page so that I stay logged into my account.

I use Firefox on Linux to do this.

I have just now tried Opera on Windows and the exact same thing happens.

HAve also tried Explorer on Windows and does the same thing as well.

The "Stay logged In" box is ticked on the log in screen but makes no difference.

So three different browsers and two different Operating Systems with the same result.

Thanks

Conan

ID: 502 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Conan
Avatar

Send message
Joined: 3 Sep 11
Posts: 26
Credit: 2,366,782
RAC: 1,198
Message 503 - Posted: 12 Mar 2012, 12:41:31 UTC - in response to Message 501.  

Sometimes this can be a corrupted login cookie, perhaps relating to the old address. Deleting all cookies relating in any way to the project and starting from scratch can clear it.


G'Day Richard,
I clear all my data on my Windows computer each internet session. So there are no cookies to refer to. That goes for Opera. On Explorer I don't normally use this programme at all so there are no stored cookies there either.

Conan
ID: 503 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
frankhagen

Send message
Joined: 19 Aug 11
Posts: 76
Credit: 2,002,860
RAC: 0
Message 504 - Posted: 12 Mar 2012, 14:32:54 UTC - in response to Message 503.  

it allways happens if i end up on http://stat.la.asu.edu/NumberFields/

for whatever reason.

the browser has a cookie for numberfields.asu.edu - so not usable on the other URL.
ID: 504 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 891
Credit: 92,319,798
RAC: 54,831
Message 507 - Posted: 12 Mar 2012, 16:40:20 UTC - in response to Message 504.  

This is turning out to be a harder problem than I expected. But you guys have all given me some clues as to where to look. I also posted a question on the boinc projects mailing list, but haven't heard anything back yet.

I think Richard may be right, that this is a cookie related problem. Because the part of the php code where things seem to break down is in a function "get_logged_in_user" which is returning null (instead of the user name). This function happens to be doing some database authentication with a variable "_COOKIE".
ID: 507 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : News : NumberFields@home still under construction


Main page · Your account · Message boards


Copyright © 2019 Arizona State University