Posts by tictoc

1) Message boards : News : GPU app - beta version for linux nvidia (Message 2209)
Posted 23 Mar 2019 by tictoc
Post:
If you want to target users that are running the "standard" drivers from popular distros like Ubuntu (LTS), Mint, and Debian, then you will probably need to build the app with the CUDA 9.1 Toolkit. Apps built with the older toolkit will still be compatible with newer GPUs. Below is a table from the CUDA Toolkit docs that lists Toolkit version with minimum driver requirements. Not sure which libraries you are using for your application, so using the older toolkit may or may not affect performance.

CUDA Toolkit and Compatible Linux Driver Versions
CUDA 10.1.105 >= 418.39
CUDA 10.0.130 >= 410.48
CUDA 9.2 (9.2.148 Update 1) >= 396.37
CUDA 9.2 (9.2.88) >= 396.26
CUDA 9.1 (9.1.85) >= 390.46
CUDA 9.0 (9.0.76) >= 384.81
CUDA 8.0 (8.0.61 GA2) >= 375.26
CUDA 8.0 (8.0.44) >= 367.48
CUDA 7.5 (7.5.16) >= 352.31
CUDA 7.0 (7.0.28) >= 346.46





Main page · Your account · Message boards


Copyright © 2022 Arizona State University