Posts by CosminZ

1) Message boards : News : New GPU OpenCL versions available (Message 3048)
Posted 6 Feb 2021 by CosminZ
Post:
The last driver version from amd site changed the opencl from "pal" to "rocr" for cards build after vega and this might be the problem. Amd RX580 it is using the same version of opencl=legacy for cards build before vega64.
RadeonOpenCompute, rocm4.0.1 it is open source driver and it comes with all the new libraries and compilers and this can create problems, one boinc project results in errors with this driver but works with amd driver. The app settings were standard and it looked like it tried to fill the gpu memory , from 0 to 700mb to 1200mb all the way to 3200-3500mb and back to zero every 2-3 seconds.
2) Message boards : News : New GPU OpenCL versions available (Message 3046)
Posted 6 Feb 2021 by CosminZ
Post:
On linux with amd vega64 it got stock with 100% utilization and 80w power usage (not doing anything), until i disabled the screen saver. After that worked for 2 days without any problem.
For vega64 the app is very inefficient, 7 minutes for a workunit at 160-170w and maximum stable is numBlocks 1024 with threadsPerBlock 64. Running 2 workunits it hangs with the same 100% utilization and 80w power usage. Amd driver apencl=rocr.
A linux laptop with amd rx580 finishes in 8 to 8:10 minutes using 40w with 1024-64 settings, and 9:30 minutes using 38-40w with 1024-32. Many workunits error up with "SIGSEGV: segmentation violation" using amd driver opencl=legacy,rocr.
Both graphics cards with rocm 4.0.1 driver have a memory problem, memory goes from 0 to 3200-3500mb and back every 2-3 seconds with lag in desktop and running times in hours.
3) Message boards : News : New and improved apps coming soon (Message 2989)
Posted 6 Jan 2021 by CosminZ
Post:
Same error on a RTX 2070m tested with the settings from GTX 1070 and after reducing the numblocks to 1024 got the same error.


<core_client_version>7.16.14</core_client_version>
<![CDATA[
<message>
process exited with code 1 (0x1, -255)</message>
<stderr_txt>
GPU Summary String = [CUDA|GeForceRTX2070|1|4095MB|45545|102].
Loading GPU lookup table from file.
GPU found in lookup table:
GPU Name = RTX2070.
numBlocks = 1024.
threadsPerBlock = 512.
polyBufferSize = 524288.
Setting GPU device number 0.
Cuda initialization was successful.
CHECKPOINT_FILE = wu_sf3_DS-16x271-1_Grp17910of2000000_checkpoint.
Checkpoint Flag = 0.
Reading file ../../projects/numberfields.asu.edu_NumberFields/sf3_DS-16x271-1_Grp17910of2000000.dat
K = x^2 - 2
S = [2, 5]
Disc Bound = 2000000000000000000
Skip = (P^3)*(Q^5)
Num Congruences = 25
SCALE = 1.000000
|dK| = 8
Signature = [2,0]
Opening output file ../../projects/numberfields.asu.edu_NumberFields/wu_sf3_DS-16x271-1_Grp17910of2000000_0_r1623407575_0
Now starting the targeted Martinet search:
Num Cvecs = 25.
Doing Cvec 1.
Doing Cvec 2.
Doing Cvec 3.
Doing Cvec 4.
Doing Cvec 5.
Doing Cvec 6.
Doing Cvec 7.
Doing Cvec 8.
Doing Cvec 9.
Doing Cvec 10.
Error code 701: too many resources requested for launch file polDiscTest_gpuCuda.cu line 2298.
polDisc Test had an error. Aborting.

</stderr_txt>
]]>


ThreadsPerBlock must be a multiple of 32, what about numBlocks? What is the relation with the cuda cores or other value.

ThreadsPerBlock tested at 64, 128, 256 and all working.
Is a way to check the same workunit to see any improvement when changing a setting, because of the run time difference between workunits.





Main page · Your account · Message boards


Copyright © 2021 Arizona State University