New GPU OpenCL versions available

Message boards : News : New GPU OpenCL versions available
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 . . . 6 · Next

AuthorMessage
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2639 - Posted: 15 Feb 2020, 13:07:42 UTC - in response to Message 2637.  

Thanks for the reply, but I have also tried various versions of the drivers, both beta and certified and I have always had the same problem and only with your project.
I also wanted to report that I do not receive the notification email when someone replies in the forum you have my messages, despite having ticked the box to immediately receive the notification via email in the preferences and I also checked in the junk mail if by chance there was.
ID: 2639 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2640 - Posted: 15 Feb 2020, 18:17:26 UTC - in response to Message 2639.  

Thanks for the reply, but I have also tried various versions of the drivers, both beta and certified and I have always had the same problem and only with your project.
I also wanted to report that I do not receive the notification email when someone replies in the forum you have my messages, despite having ticked the box to immediately receive the notification via email in the preferences and I also checked in the junk mail if by chance there was.


I will look into the email notification problem.
ID: 2640 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2644 - Posted: 16 Feb 2020, 20:28:45 UTC - in response to Message 2640.  

Thanks for the reply, but I have also tried various versions of the drivers, both beta and certified and I have always had the same problem and only with your project.
I also wanted to report that I do not receive the notification email when someone replies in the forum you have my messages, despite having ticked the box to immediately receive the notification via email in the preferences and I also checked in the junk mail if by chance there was.


I will look into the email notification problem.


I can't find any reason for your email notification problem. Maybe your ISP is filtering it before it gets to your email client?

If anyone else also has this problem please let me know.
ID: 2644 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2645 - Posted: 16 Feb 2020, 23:21:11 UTC - in response to Message 2644.  

As i know my ISP should not filter messages.
I got your email and I answered you.
Thank you.
ID: 2645 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2646 - Posted: 17 Feb 2020, 12:22:53 UTC - in response to Message 2645.  
Last modified: 17 Feb 2020, 12:27:54 UTC

I did a test, disconnected myself to the project and then reconnected with BOINC client.
He downloaded me all the necessary files and 2 wu, one for the CPU and one for the GPU and all 2 processing started.
Looking in the slot directories where they are processing I noticed that in the CPU there are 8 files:

wu_sf3_DS-14x271_Grp1669265of3932160_checkpoint
boinc_task_state.xml
boinc_lockfile
init_data.xml
stderr.txt
GetDecics_3.00_windows_x86_64
In
Out

While in the GPU there are 8 files:

boinc_lockfile
GetDecics_3.05_windows_x86_64__opencl_amd
gpuMultiPrecAMD.h
In
init_data.xml
Out
pdtKernelAMD.cl
stderr.txt

CPU wu processing progresses every 2 minutes or so, while GPU processing has stopped at 10.020% despite continuing processing.

This morning when I turned on the PC and started BOINC, the percentage of the CPU wu progressed from where it stopped last night and then progressed, while that of the GPU wu started from scratch and after 25 seconds it came to 10.020% and from there it does not move , as I said in the previous posts.

I hope I've helped you better understand my problem.
Good luck with your work.

Ah I forgot, a curiosity, how come application files don't have the .exe extension?
ID: 2646 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2647 - Posted: 17 Feb 2020, 16:27:28 UTC - in response to Message 2646.  

Ah I forgot, a curiosity, how come application files don't have the .exe extension?


The .exe extension is just a windows convention, but is not required.
ID: 2647 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2649 - Posted: 17 Feb 2020, 23:43:43 UTC - in response to Message 2647.  

OK and for the rest of the message you tell me?
ID: 2649 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2650 - Posted: 18 Feb 2020, 4:10:12 UTC - in response to Message 2649.  

OK and for the rest of the message you tell me?


The contents of the slot directories sounds right. And it sounds like the GPU is still hanging in the same spot. Again, I think this is an AMD openCL driver issue. I actually saw something similar on the linux side in the early days which went away once I got the driver installed correctly.
ID: 2650 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
SystemViper
Avatar

Send message
Joined: 13 Mar 19
Posts: 5
Credit: 39,669,975
RAC: 0
Message 2651 - Posted: 18 Feb 2020, 4:50:34 UTC
Last modified: 18 Feb 2020, 4:51:44 UTC

Hi, say i run cpu only, am i at a big disadvantage for people using gpu's or is the time spent and difficulty set up to kinda keep the WU points close?

i'm running win 10 as my os....

im just looking for a general answer, doesn't have to be that specific...

thanks in advance!

-steve
ID: 2651 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2652 - Posted: 18 Feb 2020, 5:06:42 UTC - in response to Message 2651.  

Hi, say i run cpu only, am i at a big disadvantage for people using gpu's or is the time spent and difficulty set up to kinda keep the WU points close?

i'm running win 10 as my os....

im just looking for a general answer, doesn't have to be that specific...

thanks in advance!

-steve


I would say you're not at a disadvantage if you run cpu only. My 32 core Threadripper is wracking up more credit than my 3 GPUs combined, but of course it all depends on your particular cpu/gpu combination.
ID: 2652 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
SystemViper
Avatar

Send message
Joined: 13 Mar 19
Posts: 5
Credit: 39,669,975
RAC: 0
Message 2653 - Posted: 18 Feb 2020, 23:16:34 UTC - in response to Message 2651.  

Thanks Eric, appreciate your time and efforts here...
also just wanted to say hello, looks like a smooth operation

my rigs have been running nice on win 10, going to be changing over to mint, it will be interesting to see if one OS does better then another.
Looking forward to rocking out some more wu's on this project.

thanks
-steve
ID: 2653 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2654 - Posted: 18 Feb 2020, 23:19:46 UTC - in response to Message 2650.  

The contents of the slot directories sounds right. And it sounds like the GPU is still hanging in the same spot. Again, I think this is an AMD openCL driver issue. I actually saw something similar on the linux side in the early days which went away once I got the driver installed correctly.


Reading the message gave me the idea to try some driver versions and I had the following results:

amd radeon 20.2.1 driver does not work with numberfield
amd radeon 20.1.3 driver does not work with numberfield
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 3004.8 (PAL,LC), device version OpenCL 2.0 AMD-APP (3004.8), 8176MB, 8176MB available, 4685 GFLOPS peak)

amd radeon driver 19.9.2 works with numberfield
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 2906.10 (PAL,LC), device version OpenCL 2.0 AMD-APP (2906.10), 8176MB, 8176MB available, 4685 GFLOPS peak).

Now I have installed version 19.10.1 which has the same OpenCL version as the 19.9.2, so in theory, it should work.
When I get an WU to process, I'll let you know.
I forgot to say that the WU x the CPU finished it in about 2 hours and 15 minutes, while that x the GPU in about 10 minutes with the version of the working drivers.
ID: 2654 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2655 - Posted: 19 Feb 2020, 1:19:21 UTC - in response to Message 2654.  

The contents of the slot directories sounds right. And it sounds like the GPU is still hanging in the same spot. Again, I think this is an AMD openCL driver issue. I actually saw something similar on the linux side in the early days which went away once I got the driver installed correctly.


Reading the message gave me the idea to try some driver versions and I had the following results:

amd radeon 20.2.1 driver does not work with numberfield
amd radeon 20.1.3 driver does not work with numberfield
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 3004.8 (PAL,LC), device version OpenCL 2.0 AMD-APP (3004.8), 8176MB, 8176MB available, 4685 GFLOPS peak)

amd radeon driver 19.9.2 works with numberfield
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 2906.10 (PAL,LC), device version OpenCL 2.0 AMD-APP (2906.10), 8176MB, 8176MB available, 4685 GFLOPS peak).

Now I have installed version 19.10.1 which has the same OpenCL version as the 19.9.2, so in theory, it should work.
When I get an WU to process, I'll let you know.
I forgot to say that the WU x the CPU finished it in about 2 hours and 15 minutes, while that x the GPU in about 10 minutes with the version of the working drivers.


That's good to hear you found a working driver. Strange that the newer driver is the one that fails. Your timing sounds good and is what I am used to seeing.
ID: 2655 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2656 - Posted: 21 Feb 2020, 22:56:42 UTC - in response to Message 2655.  

Here I am, for an update, as I imagined theoretically even version 19.10.1 worked and the GPU took about 54 minutes to process the WU.
Now I'm going to install version 19.12.2 of the Amd Radeon drives and then update it as soon as I get a wu to process.
ID: 2656 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2657 - Posted: 22 Feb 2020, 23:40:09 UTC - in response to Message 2656.  

Update.
I received the wu and with drivers amd radeon 19.12.2 does not work with numberfield, the processing progress percentage stops at 10.020% as in versions 20.2.1 and 20.1.3.
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 3004.7 (PAL,LC), device version OpenCL 2.0 AMD-APP (3004.7), 8176MB, 8176MB available, 4685 GFLOPS peak).

Apparently these last 3 versions that belong to Radeon Software Adrenalin 2020 Edition do not work, why?

Have they updated the OpenCL compilers?
Eric do you need to recompile the applications?

I hope I've been helpful and have an answer.

Thank you and good work.
ID: 2657 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2659 - Posted: 23 Feb 2020, 2:54:22 UTC - in response to Message 2657.  

Update.
I received the wu and with drivers amd radeon 19.12.2 does not work with numberfield, the processing progress percentage stops at 10.020% as in versions 20.2.1 and 20.1.3.
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 3004.7 (PAL,LC), device version OpenCL 2.0 AMD-APP (3004.7), 8176MB, 8176MB available, 4685 GFLOPS peak).

Apparently these last 3 versions that belong to Radeon Software Adrenalin 2020 Edition do not work, why?

Have they updated the OpenCL compilers?
Eric do you need to recompile the applications?

I hope I've been helpful and have an answer.

Thank you and good work.


Thanks for testing!

Recompiling the apps would have no effect - since I haven't changed them it would just give the same executable. The likely culprit is the AMD openCL compiler, since it compiles the code at runtime. Did the openCL version change between drivers?
ID: 2659 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Richard Haselgrove

Send message
Joined: 28 Oct 11
Posts: 179
Credit: 234,261,159
RAC: 124,699
Message 2661 - Posted: 23 Feb 2020, 7:58:55 UTC - in response to Message 2659.  

A problem has been reported with the Adrenalin 2020 drivers affecting the third-party SETI@Home OpenCL application, especially on RX 57xx cards. That problem was acknowledged and fixed in Beta version 20.1.1, and release version 20.1.3
ID: 2661 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2662 - Posted: 23 Feb 2020, 17:52:11 UTC - in response to Message 2659.  

Update.
I received the wu and with drivers amd radeon 19.12.2 does not work with numberfield, the processing progress percentage stops at 10.020% as in versions 20.2.1 and 20.1.3.
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 3004.7 (PAL,LC), device version OpenCL 2.0 AMD-APP (3004.7), 8176MB, 8176MB available, 4685 GFLOPS peak).

Apparently these last 3 versions that belong to Radeon Software Adrenalin 2020 Edition do not work, why?

Have they updated the OpenCL compilers?
Eric do you need to recompile the applications?

I hope I've been helpful and have an answer.

Thank you and good work.


Thanks for testing!

Recompiling the apps would have no effect - since I haven't changed them it would just give the same executable. The likely culprit is the AMD openCL compiler, since it compiles the code at runtime. Did the openCL version change between drivers?

Mine was just a guess, not knowing more than fish to catch to try to solve the problem.
Under each version of the drivers I had entered what appears to me in the event log of the BOINC client.
At this time I reinstalled the amd radeon 20.1.3 drivers that does not work with numberfield and this and what is written in the event log of the BOINC client:
OpenCL: AMD/ATI GPU 0: AMD Radeon RX 5700 XT 50th Anniversary (driver version 3004.8 (PAL,LC), device version OpenCL 2.0 AMD-APP (3004.8), 8176MB, 8176MB available, 4685 GFLOPS peak).
If you need anything else, let me know.
ID: 2662 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mg13 [HWU]
Avatar

Send message
Joined: 24 May 19
Posts: 38
Credit: 1,287,375
RAC: 215
Message 2663 - Posted: 23 Feb 2020, 17:56:15 UTC - in response to Message 2661.  

A problem has been reported with the Adrenalin 2020 drivers affecting the third-party SETI@Home OpenCL application, especially on RX 57xx cards. That problem was acknowledged and fixed in Beta version 20.1.1, and release version 20.1.3

Thank you for reporting, but I already knew and in fact that's why I reinstalled the drivers amd radeon 20.1.3.
The problem here is not of the wrong results, but that fails has to produce them.
ID: 2663 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Eric Driver
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 8 Jul 11
Posts: 1333
Credit: 452,708,441
RAC: 557,304
Message 2664 - Posted: 23 Feb 2020, 18:12:37 UTC - in response to Message 2663.  

I think the main point here is that the latest drivers from AMD are buggy, and although the latest release fixed the SETI problem, there are still other bugs affecting NumberFields.

Thanks to the testing of mg13, we can say that driver version 19.10.1 or earlier are good.
ID: 2664 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · 4 · 5 . . . 6 · Next

Message boards : News : New GPU OpenCL versions available


Main page · Your account · Message boards


Copyright © 2024 Arizona State University